summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 14:29:52 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 14:29:52 +0100
commite642d63b76f312686abb642150cb4e51cec116bb (patch)
tree26fe04bf28f96e5d86c1279748df69ec86fd6a24
downloadaur-e642d63b76f312686abb642150cb4e51cec116bb.tar.gz
Update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91329cc48d56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-xmlrpcpp
+ pkgdesc = ROS - XmlRpc++ is a C++ implementation of the XML-RPC protocol.
+ pkgver = 1.13.6
+ pkgrel = 3
+ url = http://xmlrpcpp.sourceforge.net
+ arch = any
+ license = LGPL-2.1
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-cpp-common
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-rostime
+ depends = ros-melodic-cpp-common
+ depends = ros-melodic-rostime
+ source = ros-melodic-xmlrpcpp-1.13.6-2.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/xmlrpcpp/1.13.6-2.tar.gz
+ sha256sums = 4ffa37f5948716a1a00f1e5710a1a54af4d8d88b5ca048d43f6f44a6be6b9cd3
+
+pkgname = ros-melodic-xmlrpcpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b3fa75b1236
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - XmlRpc++ is a C++ implementation of the XML-RPC protocol."
+url='http://xmlrpcpp.sourceforge.net'
+
+pkgname='ros-melodic-xmlrpcpp'
+pkgver='1.13.6'
+_pkgver_patch=2
+arch=('any')
+pkgrel=3
+license=('LGPL-2.1')
+
+ros_makedepends=(ros-melodic-cpp-common
+ ros-melodic-catkin
+ ros-melodic-rostime)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-cpp-common
+ ros-melodic-rostime)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/xmlrpcpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-melodic-xmlrpcpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/xmlrpcpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('4ffa37f5948716a1a00f1e5710a1a54af4d8d88b5ca048d43f6f44a6be6b9cd3')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}