summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammad Farzan2021-12-29 14:58:59 +0330
committerGitHub Action2021-12-29 11:46:29 +0000
commit073057da364100718b108300c53008351acbe5ed (patch)
treefe2a6b2fcbb8171916d6492863436d8ea6e3746d
parent193b916c45290bc33086f3b8f4b4f6f5dbd756da (diff)
downloadaur-073057da364100718b108300c53008351acbe5ed.tar.gz
Fix rviz_assimp_vendor issue (#10)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--rviz_assimp_vendor.patch14
3 files changed, 23 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1af34396b399..8024d44613ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros2-galactic
pkgdesc = A set of software libraries and tools for building robot applications
pkgver = 2021.07.16
- pkgrel = 4
+ pkgrel = 5
url = https://docs.ros.org/en/galactic/
install = ros2-galactic.install
arch = any
@@ -12,7 +12,9 @@ pkgbase = ros2-galactic
depends = sip4
source = ros2::git+https://github.com/ros2/ros2#tag=release-galactic-20210716
source = google_benchmark_vendor.patch
+ source = rviz_assimp_vendor.patch
sha256sums = SKIP
sha256sums = 609a5260736192608582c0f0a0fd4da09a9185d95d452a92d9527af38d720f6a
+ sha256sums = 1c097a78a023956fcf877e53ca35e2949a7956045deaf5f7b049a2b237fb391c
pkgname = ros2-galactic
diff --git a/PKGBUILD b/PKGBUILD
index cf37fa1b906f..287e58d43911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=ros2-galactic
pkgver=2021.07.16
-pkgrel=4
+pkgrel=5
pkgdesc="A set of software libraries and tools for building robot applications"
url="https://docs.ros.org/en/galactic/"
arch=('any')
@@ -22,10 +22,12 @@ depends=(
source=(
"ros2::git+https://github.com/ros2/ros2#tag=release-galactic-20210716"
"google_benchmark_vendor.patch"
+ "rviz_assimp_vendor.patch"
)
sha256sums=(
'SKIP'
"609a5260736192608582c0f0a0fd4da09a9185d95d452a92d9527af38d720f6a"
+ "1c097a78a023956fcf877e53ca35e2949a7956045deaf5f7b049a2b237fb391c"
)
install=ros2-galactic.install
@@ -56,6 +58,9 @@ prepare() {
git -C $srcdir/ros2/src/ros2/ros1_bridge revert 81b7610568286ec7b390c64cf6207b362d0a6550 --no-edit
## rcl_logging
git -C $srcdir/ros2/src/ros2/rcl_logging cherry-pick 77b5b2a6c948a6db1986501edc83f12ceadedba3
+ ## rviz_assimp_vendor
+ git -C $srcdir/ros2/src/ros2/rviz checkout .
+ git -C $srcdir/ros2/src/ros2/rviz apply $srcdir/rviz_assimp_vendor.patch
}
build() {
diff --git a/rviz_assimp_vendor.patch b/rviz_assimp_vendor.patch
new file mode 100644
index 000000000000..120499c4f2a1
--- /dev/null
+++ b/rviz_assimp_vendor.patch
@@ -0,0 +1,14 @@
+Credit: https://github.com/ros2/ros2/issues/1222#issuecomment-994207211
+diff --git a/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in b/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in
+index 8e41fe66..929f659c 100644
+--- a/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in
++++ b/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in
+@@ -25,7 +25,7 @@ foreach(library IN LISTS ASSIMP_LIBRARIES)
+ if(IS_ABSOLUTE "${library}")
+ list(APPEND rviz_assimp_vendor_LIBRARIES "${library}")
+ else()
+- find_library(library_abs ${library} PATHS "${ASSIMP_LIBRARY_DIRS}" NO_DEFAULT_PATH)
++ find_library(library_abs assimp)
+ list(APPEND rviz_assimp_vendor_LIBRARIES "${library_abs}")
+ endif()
+ endforeach()