summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWojciech Madry2022-08-27 10:10:11 +0200
committerGitHub Action2022-08-27 11:41:21 +0000
commit33f0f0f5507c5260039fd0e39a6bc9fa6189483d (patch)
treebb048c429cf576e897a0d50b850d615bb56ee47b
parentcd1e874ae4de79d6eb4cbdbfcfa388bcd85cca38 (diff)
downloadaur-33f0f0f5507c5260039fd0e39a6bc9fa6189483d.tar.gz
Fix `free` translation error
* If your system language is other than English, output from 'free' command is translated Signed-off-by: Wojciech Madry <madrywojciech99@gmail.com>
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ef898de33f6..739caff36ae4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -85,7 +85,8 @@ prepare() {
build() {
# Disable parallel build if RAM is low
- if [[ $(free | grep -Po "Mem:\s+\K\d+") -lt 16000000 ]]; then
+ MIN_PARALLEL_BUILD_RAM_KB=16000000
+ if [[ $(free | grep -Po "Mem:\s+\K\d+") -lt $MIN_PARALLEL_BUILD_RAM_KB && $(grep MemTotal /proc/meminfo | grep -Po "MemTotal:\s+\K\d+") -lt $MIN_PARALLEL_BUILD_RAM_KB ]]; then
printf "\nRAM is smaller than 16 GB. Parallel build will be disabled for stability.\n\n"
export COLCON_EXTRA_ARGS="${COLCON_EXTRA_ARGS} --executor sequential"
fi