summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuanyuyuan2021-08-07 13:02:22 +0800
committerMohammad Farzan2021-08-07 14:21:43 +0430
commit3f762547826cd74a7c834a0fc8d2f7788b978235 (patch)
tree73aee453f09a6d72e0ba134cac77587c4182579c
parenta890d28e4d4981a857107e448b88e712c9511084 (diff)
downloadaur-3f762547826cd74a7c834a0fc8d2f7788b978235.tar.gz
Upgrade to Patch Release 1 (#3)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD93
-rw-r--r--ros2-galactic.install13
3 files changed, 56 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb9a9c65f26d..4b9e259eb41e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros2-galactic
pkgdesc = A set of software libraries and tools for building robot applications
- pkgver = 2021.05.23
- pkgrel = 4
+ pkgver = 2021.07.16
+ pkgrel = 1
url = https://docs.ros.org/en/galactic/
install = ros2-galactic.install
arch = any
@@ -9,7 +9,7 @@ pkgbase = ros2-galactic
depends = ros2-arch-deps
depends = gmock
depends = sip4
- source = ros2::git+https://github.com/ros2/ros2#tag=release-galactic-20210523
+ source = ros2::git+https://github.com/ros2/ros2#tag=release-galactic-20210716
source = google_benchmark_vendor.patch
sha256sums = SKIP
sha256sums = 609a5260736192608582c0f0a0fd4da09a9185d95d452a92d9527af38d720f6a
diff --git a/PKGBUILD b/PKGBUILD
index e0473ec46c3e..e6052991b213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,72 +4,79 @@
# package, maintained by T. Borgert.
pkgname=ros2-galactic
-pkgver=2021.05.23
-pkgrel=4
+pkgver=2021.07.16
+pkgrel=1
pkgdesc="A set of software libraries and tools for building robot applications"
url="https://docs.ros.org/en/galactic/"
arch=('any')
license=('Apache')
depends=(
- 'ros2-arch-deps'
- 'gmock'
- 'sip4'
+ 'ros2-arch-deps'
+ 'gmock'
+ 'sip4'
)
source=(
- "ros2::git+https://github.com/ros2/ros2#tag=release-galactic-20210523"
- "google_benchmark_vendor.patch"
+ "ros2::git+https://github.com/ros2/ros2#tag=release-galactic-20210716"
+ "google_benchmark_vendor.patch"
)
sha256sums=(
- 'SKIP'
- "609a5260736192608582c0f0a0fd4da09a9185d95d452a92d9527af38d720f6a"
+ 'SKIP'
+ "609a5260736192608582c0f0a0fd4da09a9185d95d452a92d9527af38d720f6a"
)
install=ros2-galactic.install
prepare() {
- # Check locale
- locale | grep LANG | grep UTF-8
- if [[ $? -ne 0 ]]; then
- printf "Locale must support UTF-8. See https://wiki.archlinux.org/index.php/locale
- or https://wiki.archlinux.org/index.php/locale ."
- exit 1
- fi
+ # Check locale
+ locale | grep LANG | grep UTF-8
+ if [[ $? -ne 0 ]]; then
+ printf "Locale must support UTF-8. See https://wiki.archlinux.org/index.php/locale
+ or https://wiki.archlinux.org/index.php/locale ."
+ exit 1
+ fi
- # Clone the repos
- mkdir -p $srcdir/ros2/src
- vcs import $srcdir/ros2/src < $srcdir/ros2/ros2.repos
+ # Create required symlinks (see https://wiki.archlinux.org/index.php/ROS)
+ if [ ! -d /usr/share/sip/PyQt5 ]; then
+ sudo mkdir -p /usr/share/sip
+ sudo ln -sf /usr/lib/python3.9/site-packages/PyQt5 /usr/share/sip/.
+ sudo ln -sf /usr/lib/python3.9/site-packages/PyQt5/bindings/* /usr/share/sip/PyQt5/.
+ fi
- # Fix some issues in the code (TODO: Gradually move to upstream)
- ## google_benchmark_vendor
- git -C $srcdir/ros2/src/ament/google_benchmark_vendor checkout .
- git -C $srcdir/ros2/src/ament/google_benchmark_vendor apply $srcdir/google_benchmark_vendor.patch
- ## Eclipse iceoryx
- git -C $srcdir/ros2/src/eclipse-iceoryx/iceoryx checkout release_1.0
- ## Eclipse CycloneDDS
- git -C $srcdir/ros2/src/eclipse-cyclonedds/cyclonedds checkout 0.8.0beta6
- git -C $srcdir/ros2/src/eclipse-cyclonedds/cyclonedds cherry-pick bdf270a588aae77d0f1a0f0070b53ad1388da61c
+ # Clone the repos
+ mkdir -p $srcdir/ros2/src
+ vcs import $srcdir/ros2/src < $srcdir/ros2/ros2.repos
+
+ # Fix some issues in the code (TODO: Gradually move to upstream)
+ ## google_benchmark_vendor: apply patch to update google_benchmark to v1.5.4
+ git -C $srcdir/ros2/src/ament/google_benchmark_vendor checkout .
+ git -C $srcdir/ros2/src/ament/google_benchmark_vendor apply $srcdir/google_benchmark_vendor.patch
+ ## Eclipse iceoryx: fix building error with GCC 11
+ git -C $srcdir/ros2/src/eclipse-iceoryx/iceoryx checkout v1.0.1
+ ## Eclipse CycloneDDS: latest release
+ git -C $srcdir/ros2/src/eclipse-cyclonedds/cyclonedds checkout 0.8.0rc1
+ ## yaml_cpp_vendor: fix handling of CMAKE_C[XX]_FLAGS lists
+ git -C $srcdir/ros2/src/ros2/yaml_cpp_vendor checkout a00f059a79e98bd3899e8fe4261ea61da807b6ef
## ros1_bridge
git -C $srcdir/ros2/src/ros2/ros1_bridge revert 81b7610568286ec7b390c64cf6207b362d0a6550 --no-edit
}
build() {
- # Disable parallel build if RAM is low
- if [[ $(free | grep -Po "Mem:\s+\K\d+") < 16000000 ]]; then
- printf "\nRAM is smaller than 16 GB. Parallel build will be disabled for stability.\n\n"
- export COLCON_EXTRA_ARGS="${COLCON_EXTRA_ARGS} --executor sequential"
- fi
+ # Disable parallel build if RAM is low
+ if [[ $(free | grep -Po "Mem:\s+\K\d+") < 16000000 ]]; then
+ printf "\nRAM is smaller than 16 GB. Parallel build will be disabled for stability.\n\n"
+ export COLCON_EXTRA_ARGS="${COLCON_EXTRA_ARGS} --executor sequential"
+ fi
- # Disable -D_FORTIFY_SOURCE=2 flag (Required to build mimick_vendor)
- ## For people with the old version of makepkg.conf
- unset CPPFLAGS
- ## For people with the new version of makepkg.conf
- CFLAGS=$(sed "s/-Wp,-D_FORTIFY_SOURCE=2\s//g" <(echo $CFLAGS))
- CXXFLAGS=$(sed "s/-Wp,-D_FORTIFY_SOURCE=2\s//g" <(echo $CXXFLAGS))
+ ## For people with the old version of makepkg.conf
+ unset CPPFLAGS
+ ## For people with the new version of makepkg.conf
+ CFLAGS=$(sed "s/-Wp,-D_FORTIFY_SOURCE=2\s//g" <(echo $CFLAGS))
+ CXXFLAGS=$(sed "s/-Wp,-D_FORTIFY_SOURCE=2\s//g" <(echo $CXXFLAGS))
- # Build
- colcon build --merge-install ${COLCON_EXTRA_ARGS}
+ # Build
+ colcon build --merge-install ${COLCON_EXTRA_ARGS}
}
package() {
- mkdir -p $pkgdir/opt/ros2/galactic
- cp -r $srcdir/install/* $pkgdir/opt/ros2/galactic/
+ mkdir -p $pkgdir/opt/ros2/galactic
+ cp -r $srcdir/install/* $pkgdir/opt/ros2/galactic/
}
diff --git a/ros2-galactic.install b/ros2-galactic.install
index 3a08069c151b..e048f7795675 100644
--- a/ros2-galactic.install
+++ b/ros2-galactic.install
@@ -1,10 +1,3 @@
-pre_install() {
- # Create required symlinks (see https://wiki.archlinux.org/index.php/ROS)
- mkdir -p /usr/share/sip
- ln -sf /usr/lib/python3.9/site-packages/PyQt5 /usr/share/sip/.
- ln -sf /usr/lib/python3.9/site-packages/PyQt5/bindings/* /usr/share/sip/PyQt5/.
-}
-
post_install() {
printf "
\e[33m\e[1mIMPORTANT NOTE:\e[0m
@@ -12,14 +5,14 @@ post_install() {
export ROS_DOMAIN_ID=42
source /opt/ros2/galactic/setup.bash
-
+
This quick command will do it for you:
-
+
printf \"\\\nexport ROS_DOMAIN_ID=42\\\nsource /opt/ros2/galactic/setup.bash\\\n\" >> ~/.bashrc
Note 1: If you use zsh, replace '.bash' in the above lines with
'.zsh' and add the lines to ~/.zshrc .
-
+
Note 2: This will slow down terminal startup for a few seconds on
cold start, and a fraction of a second for terminals that open later.
If you know a better transparent solution, you are welcome to edit