summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM. Mostafa Farzan2022-01-17 23:25:22 +0330
committerGitHub Action2022-01-17 19:55:37 +0000
commit623f114963e379fc2a4a2684a6c7209d59dae447 (patch)
treeba4a91babbab6beee9a1a609ab073945253c2ce2
parent00d4e50c17b64d117e6a6e543e4c46a230bf14c5 (diff)
downloadaur-623f114963e379fc2a4a2684a6c7209d59dae447.tar.gz
Fix locale check
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb6d0f1406c8..115036cc8a99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,11 +33,12 @@ sha256sums=(
install=ros2-galactic.install
prepare() {
- # Check locale
- locale | grep LANG | grep UTF-8
- if [[ $? -ne 0 ]]; then
- printf "Locale must support UTF-8. See https://wiki.archlinux.org/index.php/locale
- or https://wiki.archlinux.org/index.php/locale ."
+ # Check locale according to
+ # https://docs.ros.org/en/rolling/Installation/Ubuntu-Development-Setup.html#set-locale
+ if ! locale | grep LANG | grep UTF-8 > /dev/null; then
+ echo 'Your locale must support UTF-8. See ' \
+ 'https://wiki.archlinux.org/index.php/locale and ' \
+ 'https://docs.ros.org/en/rolling/Installation/Ubuntu-Development-Setup.html#set-locale'
exit 1
fi