summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammad Farzan2022-02-14 15:43:11 +0330
committerGitHub Action2022-02-14 12:13:53 +0000
commitb3b1ed8f495b5aee87db9312cb9082d7569a4bdb (patch)
treef73445e852f6d0679aa401d82e9bb5ccf0aad994
parent9ecb3ad11cf0ede794e546fc88b32432a992196c (diff)
downloadaur-b3b1ed8f495b5aee87db9312cb9082d7569a4bdb.tar.gz
Remove assimp_vendor patch (#5)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--rviz_assimp_vendor.patch14
3 files changed, 2 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 567bdab61cb3..ad33b39118fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros2-git
pkgdesc = A set of software libraries and tools for building robot applications (Rolling Distro)
pkgver = r230.4a36f31
- pkgrel = 4
+ pkgrel = 5
url = https://docs.ros.org/en/rolling/
install = ros2-git.install
arch = any
@@ -14,8 +14,6 @@ pkgbase = ros2-git
depends = sip4
provides = ros2
source = ros2::git+https://github.com/ros2/ros2#branch=master
- source = rviz_assimp_vendor.patch
sha256sums = SKIP
- sha256sums = 1c097a78a023956fcf877e53ca35e2949a7956045deaf5f7b049a2b237fb391c
pkgname = ros2-git
diff --git a/PKGBUILD b/PKGBUILD
index f9e46f2985b2..5d133af3b4d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=ros2-git
pkgver=r230.4a36f31
-pkgrel=4
+pkgrel=5
pkgdesc="A set of software libraries and tools for building robot applications (Rolling Distro)"
url="https://docs.ros.org/en/rolling/"
arch=('any')
@@ -26,11 +26,9 @@ depends=(
provides=(ros2)
source=(
"ros2::git+https://github.com/ros2/ros2#branch=master"
- "rviz_assimp_vendor.patch"
)
sha256sums=(
'SKIP'
- "1c097a78a023956fcf877e53ca35e2949a7956045deaf5f7b049a2b237fb391c"
)
install=ros2-git.install
@@ -52,11 +50,6 @@ prepare() {
# Clone the repos
mkdir -p $srcdir/ros2/src
vcs import $srcdir/ros2/src < $srcdir/ros2/ros2.repos
-
- # Fix some issues in the code (TODO: Gradually move to upstream)
- ## rviz_assimp_vendor
- git -C $srcdir/ros2/src/ros2/rviz checkout .
- git -C $srcdir/ros2/src/ros2/rviz apply $srcdir/rviz_assimp_vendor.patch
}
build() {
diff --git a/rviz_assimp_vendor.patch b/rviz_assimp_vendor.patch
deleted file mode 100644
index 120499c4f2a1..000000000000
--- a/rviz_assimp_vendor.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Credit: https://github.com/ros2/ros2/issues/1222#issuecomment-994207211
-diff --git a/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in b/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in
-index 8e41fe66..929f659c 100644
---- a/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in
-+++ b/rviz_assimp_vendor/rviz_assimp_vendor-extras.cmake.in
-@@ -25,7 +25,7 @@ foreach(library IN LISTS ASSIMP_LIBRARIES)
- if(IS_ABSOLUTE "${library}")
- list(APPEND rviz_assimp_vendor_LIBRARIES "${library}")
- else()
-- find_library(library_abs ${library} PATHS "${ASSIMP_LIBRARY_DIRS}" NO_DEFAULT_PATH)
-+ find_library(library_abs assimp)
- list(APPEND rviz_assimp_vendor_LIBRARIES "${library_abs}")
- endif()
- endforeach()