summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammad Farzan2022-08-29 11:09:34 +0430
committerGitHub Action2022-08-29 06:41:18 +0000
commitcdc45920aef1766ad1eb66d63ed7f1c1f7089202 (patch)
treee14c0668e7023bd059eb5748f4b22c4558d68e78
parentb3b1ed8f495b5aee87db9312cb9082d7569a4bdb (diff)
downloadaur-cdc45920aef1766ad1eb66d63ed7f1c1f7089202.tar.gz
Check for lowercase utf8 locale specifier
Ported from m2-farzan/ros2-galactic-PKGBUILD#29
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d133af3b4d2..b2d916d9fad3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,7 +40,7 @@ pkgver() {
prepare() {
# Check locale according to
# https://docs.ros.org/en/rolling/Installation/Ubuntu-Development-Setup.html#set-locale
- if ! locale | grep LANG | grep UTF-8 > /dev/null; then
+ if ! locale | grep LANG | grep 'UTF-8\|utf8' > /dev/null; then
echo 'Your locale must support UTF-8. See ' \
'https://wiki.archlinux.org/index.php/locale and ' \
'https://docs.ros.org/en/rolling/Installation/Ubuntu-Development-Setup.html#set-locale'