summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:50:40 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:50:40 -0300
commite843a52d2268f61eede02e1cc9c1489a86f98dd9 (patch)
tree5bbb19a81a2faa5094b6e74889c57f275b9b26db
downloadaur-e843a52d2268f61eede02e1cc9c1489a86f98dd9.tar.gz
First version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8e050a36cee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros2-humble-dwb-critics
+ pkgdesc = The dwb_critics package
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://index.ros.org/p/dwb_critics/
+ arch = any
+ makedepends = ros2-humble-nav2-common
+ depends = ros2-humble
+ depends = ros2-humble-nav2-costmap-2d
+ depends = ros2-humble-nav2-util
+ depends = ros2-humble-costmap-queue
+ depends = ros2-humble-dwb-core
+ depends = ros2-humble-nav-2d-msgs
+ depends = ros2-humble-nav-2d-utils
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
+ sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+
+pkgname = ros2-humble-dwb-critics
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9f129a82520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_dwb_controller/dwb_critics
+pkgname=ros2-humble-dwb-critics
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="The dwb_critics package"
+url="https://index.ros.org/p/dwb_critics/"
+arch=('any')
+makedepends=('ros2-humble-nav2-common')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-nav2-costmap-2d'
+ 'ros2-humble-nav2-util'
+ 'ros2-humble-costmap-queue'
+ 'ros2-humble-dwb-core'
+ 'ros2-humble-nav-2d-msgs'
+ 'ros2-humble-nav-2d-utils'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble \
+ -DCMAKE_CXX_FLAGS="-Wno-error=maybe-uninitialized"
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}