summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:11:33 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:11:33 -0300
commit1b87007553b8497262362090721b7e91aa117d99 (patch)
tree5fb73062530001c6051c8e31f0729d2c6d73c58f
parentc628d7326a3f7d096c16c64f0e977671ff3d5b55 (diff)
downloadaur-1b87007553b8497262362090721b7e91aa117d99.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cd2b32c240a..c85c82064bd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = ros2-humble-dwb-msgs
pkgdesc = Message/Service definitions specifically for the dwb_core
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/dwb_msgs/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-nav-2d-msgs
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-dwb-msgs
diff --git a/PKGBUILD b/PKGBUILD
index 790f8d4fdc63..c227ae4565aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_dwb_controller/dwb_msgs
pkgname=ros2-humble-dwb-msgs
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="Message/Service definitions specifically for the dwb_core"
url="https://index.ros.org/p/dwb_msgs/"
arch=('any')
@@ -11,22 +12,23 @@ depends=(
'ros2-humble'
'ros2-humble-nav-2d-msgs'
)
+makedepends=('cmake')
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}