summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:40:38 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:40:38 -0300
commit24b42306a6820f18fe79edc5e5a30cb86aa9854d (patch)
treedab932d4c8bcfb6f91eb15a6b453a1ac6020577f
downloadaur-24b42306a6820f18fe79edc5e5a30cb86aa9854d.tar.gz
First version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29416661bc7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ros2-humble-dwb-plugins
+ pkgdesc = Standard implementations of the GoalChecker and TrajectoryGenerators for dwb_core
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://index.ros.org/p/dwb_plugins/
+ arch = any
+ depends = ros2-humble
+ depends = ros2-humble-angles
+ depends = ros2-humble-dwb-core
+ depends = ros2-humble-nav2-util
+ depends = ros2-humble-nav-2d-msgs
+ depends = ros2-humble-nav-2d-utils
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
+ sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+
+pkgname = ros2-humble-dwb-plugins
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56c4ccba3d8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_dwb_controller/dwb_plugins
+pkgname=ros2-humble-dwb-plugins
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="Standard implementations of the GoalChecker and TrajectoryGenerators for dwb_core"
+url="https://index.ros.org/p/dwb_plugins/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-angles'
+ 'ros2-humble-dwb-core'
+ 'ros2-humble-nav2-util'
+ 'ros2-humble-nav-2d-msgs'
+ 'ros2-humble-nav-2d-utils'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}