summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:11:46 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:11:46 -0300
commit78602a30fb68a62e9f512b4cc9984ae40063a77f (patch)
tree11febc30efb16915d19100387e921d6206ffd33c
parent7e7421a3970658ed9fc4b61c85b03c76c40330a9 (diff)
downloadaur-78602a30fb68a62e9f512b4cc9984ae40063a77f.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dbbc30a33b6..a5027ae70134 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ros2-humble-dwb-plugins
pkgdesc = Standard implementations of the GoalChecker and TrajectoryGenerators for dwb_core
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/dwb_plugins/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-angles
depends = ros2-humble-dwb-core
depends = ros2-humble-nav2-util
depends = ros2-humble-nav-2d-msgs
depends = ros2-humble-nav-2d-utils
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-dwb-plugins
diff --git a/PKGBUILD b/PKGBUILD
index dad287294ef7..9ee01d621668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_dwb_controller/dwb_plugins
pkgname=ros2-humble-dwb-plugins
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="Standard implementations of the GoalChecker and TrajectoryGenerators for dwb_core"
url="https://index.ros.org/p/dwb_plugins/"
arch=('any')
@@ -15,22 +16,23 @@ depends=(
'ros2-humble-nav-2d-msgs'
'ros2-humble-nav-2d-utils'
)
+makedepends=('cmake')
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}