summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:21:36 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:21:36 -0300
commitf2b8d2023a718f7c95615a2648b91a9d1d8395f3 (patch)
tree4591aed800702b45cb6ca50803516b06c7c38b1f
parent4ef242550a98cbc666c03f321f5279e7533d4a4e (diff)
downloadaur-f2b8d2023a718f7c95615a2648b91a9d1d8395f3.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f710e22c8055..601998d464bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-eigen-stl-containers
pkgdesc = This package provides a set of typedef's that allow using Eigen datatypes in STL containers
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/eigen_stl_containers/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = eigen
source = https://github.com/ros/eigen_stl_containers/archive/refs/tags/1.0.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index e6a94e698b73..51e835f39f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=eigen_stl_containers
pkgname=ros2-humble-eigen-stl-containers
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="This package provides a set of typedef's that allow using Eigen datatypes in STL containers"
url="https://index.ros.org/p/eigen_stl_containers/"
arch=('any')
@@ -11,22 +11,23 @@ depends=(
'ros2-humble'
'eigen'
)
+makedepends=('cmake')
source=("https://github.com/ros/eigen_stl_containers/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('4780665fa22d7924072ae2fa22d98a32870becb15ce4e68c08c2de923a184583')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S eigen_stl_containers-$pkgver -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}