summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:42:36 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:42:36 -0300
commit7b210cfef5431b373ae5c4d4c8c80dd556497e7d (patch)
treeee41a38402e78881b33d11233be1c109b25e3145
downloadaur-7b210cfef5431b373ae5c4d4c8c80dd556497e7d.tar.gz
First version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b7840ee490c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ros2-humble-gazebo-msgs
+ pkgdesc = Message and service data structures for interacting with Gazebo from ROS
+ pkgver = 3.7.0
+ pkgrel = 1
+ url = https://index.ros.org/p/gazebo_msgs/
+ arch = any
+ depends = ros2-humble
+ source = https://github.com/ros-simulation/gazebo_ros_pkgs/archive/refs/tags/3.7.0.tar.gz
+ sha256sums = 69093e3cc7c4194f958bff777e76ab7c9a8f5c880f764332eb961f791a5a73a4
+
+pkgname = ros2-humble-gazebo-msgs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60fc4d384ee7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=gazebo_msgs
+pkgname=ros2-humble-gazebo-msgs
+pkgver=3.7.0
+pkgrel=1
+pkgdesc="Message and service data structures for interacting with Gazebo from ROS"
+url="https://index.ros.org/p/gazebo_msgs/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+)
+source=("https://github.com/ros-simulation/gazebo_ros_pkgs/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('69093e3cc7c4194f958bff777e76ab7c9a8f5c880f764332eb961f791a5a73a4')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S gazebo_ros_pkgs-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}