summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:25:27 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:25:27 -0300
commitc0b093bac6266be10f4a01727aef795705df0f0d (patch)
treead3d12908729e5a3de9edf19a1956ce37c187d69
parenta3322aa360a0dbef627ce2b7f6182db5cec24704 (diff)
downloadaur-c0b093bac6266be10f4a01727aef795705df0f0d.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8784658a3ac..b53c0b2dd2e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-gazebo-msgs
pkgdesc = Message and service data structures for interacting with Gazebo from ROS
pkgver = 3.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/gazebo_msgs/
arch = any
+ makedepends = cmake
depends = ros2-humble
source = https://github.com/ros-simulation/gazebo_ros_pkgs/archive/refs/tags/3.7.0.tar.gz
sha256sums = 69093e3cc7c4194f958bff777e76ab7c9a8f5c880f764332eb961f791a5a73a4
diff --git a/PKGBUILD b/PKGBUILD
index fffa9c2e882c..8317990903f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=gazebo_ros_pkgs
_pkgname=gazebo_msgs
pkgname=ros2-humble-gazebo-msgs
pkgver=3.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="Message and service data structures for interacting with Gazebo from ROS"
url="https://index.ros.org/p/gazebo_msgs/"
arch=('any')
depends=(
'ros2-humble'
)
+makedepends=('cmake')
source=("https://github.com/ros-simulation/gazebo_ros_pkgs/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('69093e3cc7c4194f958bff777e76ab7c9a8f5c880f764332eb961f791a5a73a4')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S gazebo_ros_pkgs-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}