summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:00:58 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:00:58 -0300
commit5757c2054441266fff4dfc968eb3e2cb52abd3c2 (patch)
tree3cf38dd7c6a4a2053191624e04a56ac0aca76229
parent097fb17ba83e50667f9dbff29e098d2beb756bb8 (diff)
downloadaur-5757c2054441266fff4dfc968eb3e2cb52abd3c2.tar.gz
update to 2.5.4-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 616fc10dc5fa..b340fb26e09d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros2-humble-moveit-kinematics
pkgdesc = Package for all inverse kinematics solvers in MoveIt
pkgver = 2.5.4
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/moveit_kinematics/
arch = any
makedepends = ros2-humble-moveit-common
@@ -11,6 +11,7 @@ pkgbase = ros2-humble-moveit-kinematics
makedepends = ros2-humble-moveit-resources-panda-description
makedepends = ros2-humble-moveit-resources-panda-moveit-config
makedepends = ros2-humble-moveit-configs-utils
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-moveit-core
depends = eigen
diff --git a/PKGBUILD b/PKGBUILD
index e3e28ce0218f..e39b64520dab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=moveit2
_pkgname=moveit_kinematics
pkgname=ros2-humble-moveit-kinematics
pkgver=2.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Package for all inverse kinematics solvers in MoveIt"
url="https://index.ros.org/p/moveit_kinematics/"
arch=('any')
@@ -15,6 +16,7 @@ makedepends=(
'ros2-humble-moveit-resources-panda-description'
'ros2-humble-moveit-resources-panda-moveit-config'
'ros2-humble-moveit-configs-utils'
+ 'cmake'
)
depends=(
'ros2-humble'
@@ -28,17 +30,17 @@ sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S moveit2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}