summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:01:24 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:01:24 -0300
commit73dbf3d5b684a1ee74597730b2fd1b1fb852e6e2 (patch)
treec6ac21408ee6aa3ca330fa0226fa96ff7052ccf9
parent0f456f50aecdc4b86289f77c6dbfcde71b989806 (diff)
downloadaur-73dbf3d5b684a1ee74597730b2fd1b1fb852e6e2.tar.gz
update to 2.5.4-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc53d74f3f96..c1af862bd4d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros2-humble-moveit-ros-control-interface
pkgdesc = ros_control controller manager interface for MoveIt
pkgver = 2.5.4
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/moveit_ros_control_interface/
arch = any
depends = ros2-humble
@@ -9,6 +9,7 @@ pkgbase = ros2-humble-moveit-ros-control-interface
depends = ros2-humble-controller-manager-msgs
depends = ros2-humble-moveit-core
depends = ros2-humble-moveit-simple-controller-manager
+ depends = cmake
source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
diff --git a/PKGBUILD b/PKGBUILD
index 65a491a8b2db..101731fa1df7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=moveit2
_pkgname=moveit_plugins/moveit_ros_control_interface
pkgname=ros2-humble-moveit-ros-control-interface
pkgver=2.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="ros_control controller manager interface for MoveIt"
url="https://index.ros.org/p/moveit_ros_control_interface/"
arch=('any')
@@ -13,23 +14,24 @@ depends=(
'ros2-humble-controller-manager-msgs'
'ros2-humble-moveit-core'
'ros2-humble-moveit-simple-controller-manager'
+ 'cmake'
)
source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S moveit2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}