summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:01:51 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:01:51 -0300
commit447931e42039020b84cc7b31df9d2ee037547419 (patch)
treedb9117334b632af0c363f651ad1156bf549ee9ac
parent5520eda3fadf8744359cd891788a41103d9d2596 (diff)
downloadaur-447931e42039020b84cc7b31df9d2ee037547419.tar.gz
update to 2.5.4-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f93cd9525b6e..2a69ac49b06d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = ros2-humble-moveit-ros-occupancy-map-monitor
pkgdesc = Components of MoveIt connecting to occupancy map
pkgver = 2.5.4
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/moveit_ros_occupancy_map_monitor/
arch = any
makedepends = ros2-humble-moveit-common
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-moveit-core
depends = ros2-humble-moveit-msgs
diff --git a/PKGBUILD b/PKGBUILD
index 7a8dde1995c7..b9fd5cb17fdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=moveit2
_pkgname=moveit_ros/occupancy_map_monitor
pkgname=ros2-humble-moveit-ros-occupancy-map-monitor
pkgver=2.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Components of MoveIt connecting to occupancy map"
url="https://index.ros.org/p/moveit_ros_occupancy_map_monitor/"
arch=('any')
-makedepends=('ros2-humble-moveit-common')
+makedepends=('ros2-humble-moveit-common' 'cmake')
depends=(
'ros2-humble'
'ros2-humble-moveit-core'
@@ -21,17 +22,17 @@ sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S moveit2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}