summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:53:36 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:53:36 -0300
commitc089d66e678fff72aa6786c813975c17ee91732e (patch)
treed73e198c81f42e88ea90bc6521bcfb20a7a9e673
downloadaur-c089d66e678fff72aa6786c813975c17ee91732e.tar.gz
First version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..957deb9f5fb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ros2-humble-moveit-ros-occupancy-map-monitor
+ pkgdesc = Components of MoveIt connecting to occupancy map
+ pkgver = 2.5.4
+ pkgrel = 1
+ url = https://index.ros.org/p/moveit_ros_occupancy_map_monitor/
+ arch = any
+ makedepends = ros2-humble-moveit-common
+ depends = ros2-humble
+ depends = ros2-humble-moveit-core
+ depends = ros2-humble-moveit-msgs
+ depends = octomap
+ depends = ros2-humble-geometric-shapes
+ depends = eigen
+ source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
+ sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
+
+pkgname = ros2-humble-moveit-ros-occupancy-map-monitor
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..859ea2e420d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_ros/occupancy_map_monitor
+pkgname=ros2-humble-moveit-ros-occupancy-map-monitor
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="Components of MoveIt connecting to occupancy map"
+url="https://index.ros.org/p/moveit_ros_occupancy_map_monitor/"
+arch=('any')
+makedepends=('ros2-humble-moveit-common')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-moveit-core'
+ 'ros2-humble-moveit-msgs'
+ 'octomap'
+ 'ros2-humble-geometric-shapes'
+ 'eigen'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}