summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 18:00:38 -0300
committerAngelo Elias Dal Zotto2023-03-14 18:00:38 -0300
commitf6fe5cc1ee19c2f3c6a1a653d23923f3e29e4f51 (patch)
tree1752c98dc692f163c158680bdbb8048a5ff5091a
downloadaur-f6fe5cc1ee19c2f3c6a1a653d23923f3e29e4f51.tar.gz
First version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bd8b5b3e3b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros2-humble-moveit-ros-planning
+ pkgdesc = Planning components of MoveIt that use ROS
+ pkgver = 2.5.4
+ pkgrel = 1
+ url = https://index.ros.org/p/moveit_ros_planning/
+ arch = any
+ makedepends = ros2-humble-moveit-common
+ depends = ros2-humble
+ depends = ros2-humble-moveit-core
+ depends = ros2-humble-moveit-ros-occupancy-map-monitor
+ depends = ros2-humble-moveit-msgs
+ depends = ros2-humble-srdfdom
+ depends = urdfdom
+ depends = eigen
+ source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
+ sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
+
+pkgname = ros2-humble-moveit-ros-planning
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..541ed37bbdf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_ros/planning
+pkgname=ros2-humble-moveit-ros-planning
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="Planning components of MoveIt that use ROS"
+url="https://index.ros.org/p/moveit_ros_planning/"
+arch=('any')
+makedepends=('ros2-humble-moveit-common')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-moveit-core'
+ 'ros2-humble-moveit-ros-occupancy-map-monitor'
+ 'ros2-humble-moveit-msgs'
+ 'ros2-humble-srdfdom'
+ 'urdfdom'
+ 'eigen'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}