summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:56:29 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:56:29 -0300
commit2dc2522df6d9019c13fd9a4f2db56c8d7cc95b18 (patch)
tree5e99e9b06073e304b9d5d9e435cd7a5d235f2d0e
downloadaur-2dc2522df6d9019c13fd9a4f2db56c8d7cc95b18.tar.gz
First version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a54a79d21d23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ros2-humble-moveit-ros-robot-interaction
+ pkgdesc = Components of MoveIt that offer interaction via interactive markers
+ pkgver = 2.5.4
+ pkgrel = 1
+ url = https://index.ros.org/p/moveit_ros_robot_interaction/
+ arch = any
+ depends = ros2-humble
+ depends = ros2-humble-moveit-common
+ depends = ros2-humble-moveit-core
+ depends = ros2-humble-moveit-ros-planning
+ source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
+ sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
+
+pkgname = ros2-humble-moveit-ros-robot-interaction
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd9be1399464
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_ros/robot_interaction
+pkgname=ros2-humble-moveit-ros-robot-interaction
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="Components of MoveIt that offer interaction via interactive markers"
+url="https://index.ros.org/p/moveit_ros_robot_interaction/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-moveit-common'
+ 'ros2-humble-moveit-core'
+ 'ros2-humble-moveit-ros-planning'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}