summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:46:17 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:46:17 -0300
commitbb6746cf0617d4b650f8523c2b8b8f93a1cdee24 (patch)
tree4e378ccd8fb86394a8b8ad4c7e86ec3ce27e2187
downloadaur-bb6746cf0617d4b650f8523c2b8b8f93a1cdee24.tar.gz
First version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6cf7d15ad28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ros2-humble-moveit-ros-visualization
+ pkgdesc = Components of MoveIt that offer visualization
+ pkgver = 2.5.4
+ pkgrel = 1
+ url = https://index.ros.org/p/moveit_ros_visualization/
+ arch = any
+ makedepends = eigen
+ makedepends = qt5-base
+ depends = ros2-humble
+ depends = ros2-humble-moveit-common
+ depends = ros2-humble-moveit-ros-robot-interaction
+ depends = ros2-humble-moveit-ros-planning-interface
+ depends = ros2-humble-moveit-ros-warehouse
+ source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
+ sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
+
+pkgname = ros2-humble-moveit-ros-visualization
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340bcaa600fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_ros/visualization
+pkgname=ros2-humble-moveit-ros-visualization
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="Components of MoveIt that offer visualization"
+url="https://index.ros.org/p/moveit_ros_visualization/"
+arch=('any')
+makedepends=(
+ 'eigen'
+ 'qt5-base'
+)
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-moveit-common'
+ 'ros2-humble-moveit-ros-robot-interaction'
+ 'ros2-humble-moveit-ros-planning-interface'
+ 'ros2-humble-moveit-ros-warehouse'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}