summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:40:09 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:40:09 -0300
commit3373ed904b841d0c87b6de5e466d75f817d9d853 (patch)
tree37c408d03beb0a936e7876b6a62943b279b897ac
downloadaur-3373ed904b841d0c87b6de5e466d75f817d9d853.tar.gz
First version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..355e760e8d9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ros2-humble-moveit-ros-warehouse
+ pkgdesc = Components of MoveIt connecting to MongoDB
+ pkgver = 2.5.4
+ pkgrel = 1
+ url = https://index.ros.org/p/moveit_ros_warehouse/
+ arch = any
+ makedepends = ros2-humble-moveit-common
+ depends = ros2-humble
+ depends = ros2-humble-moveit-core
+ depends = ros2-humble-warehouse-ros
+ depends = ros2-humble-moveit-ros-planning
+ source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
+ sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
+
+pkgname = ros2-humble-moveit-ros-warehouse
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4d5b1337989
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_ros/warehouse
+pkgname=ros2-humble-moveit-ros-warehouse
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="Components of MoveIt connecting to MongoDB"
+url="https://index.ros.org/p/moveit_ros_warehouse/"
+arch=('any')
+makedepends=(
+ 'ros2-humble-moveit-common'
+)
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-moveit-core'
+ 'ros2-humble-warehouse-ros'
+ 'ros2-humble-moveit-ros-planning'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}