summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:02:58 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:02:58 -0300
commitcf8fe95b433d9783ec60b2ac0778fa0e91aff74e (patch)
tree9724b919fa4bd67ae06df0c47b1923e7cf0d818a
parentdf27e41b9fb3f87f7ce84eb96de82086443bb821 (diff)
downloadaur-cf8fe95b433d9783ec60b2ac0778fa0e91aff74e.tar.gz
update to 2.5.4-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f536286a05e1..e6c0f645b094 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = ros2-humble-moveit-ros-warehouse
pkgdesc = Components of MoveIt connecting to MongoDB
pkgver = 2.5.4
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/moveit_ros_warehouse/
arch = any
makedepends = ros2-humble-moveit-common
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-moveit-core
depends = ros2-humble-warehouse-ros
diff --git a/PKGBUILD b/PKGBUILD
index dd47147290bc..fe312cf4a581 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=moveit2
_pkgname=moveit_ros/warehouse
pkgname=ros2-humble-moveit-ros-warehouse
pkgver=2.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Components of MoveIt connecting to MongoDB"
url="https://index.ros.org/p/moveit_ros_warehouse/"
arch=('any')
makedepends=(
'ros2-humble-moveit-common'
+ 'cmake'
)
depends=(
'ros2-humble'
@@ -21,17 +23,17 @@ sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S moveit2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}