summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:52:23 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:52:23 -0300
commitb0ce12d31f0eb70d7b218312501f5d352c298170 (patch)
treea5d56ac743aaea127f361858f26e3fcde33d8763
downloadaur-b0ce12d31f0eb70d7b218312501f5d352c298170.tar.gz
First version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37766696abb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ros2-humble-moveit-simple-controller-manager
+ pkgdesc = A generic, simple controller manager plugin for MoveIt
+ pkgver = 2.5.4
+ pkgrel = 1
+ url = https://index.ros.org/p/moveit_simple_controller_manager/
+ arch = any
+ makedepends = ros2-humble-moveit-common
+ depends = ros2-humble
+ depends = ros2-humble-control-msgs
+ source = https://github.com/ros-planning/moveit2/archive/refs/tags/2.5.4.tar.gz
+ sha256sums = 42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6
+
+pkgname = ros2-humble-moveit-simple-controller-manager
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c60b9aa3e8db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_plugins/moveit_simple_controller_manager
+pkgname=ros2-humble-moveit-simple-controller-manager
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="A generic, simple controller manager plugin for MoveIt"
+url="https://index.ros.org/p/moveit_simple_controller_manager/"
+arch=('any')
+makedepends=(
+ 'ros2-humble-moveit-common'
+)
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-control-msgs'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}