summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:12:37 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:12:37 -0300
commit6f64235758204a58369e0c609f0fc39c390cbca0 (patch)
tree2d8cd8b42a265af37ab6a25c1733485ba21cf2e5
parent8e17a85da33610fe745e2defde4c07ac0816cb8a (diff)
downloadaur-6f64235758204a58369e0c609f0fc39c390cbca0.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57969592a4dd..731aae1550a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = ros2-humble-nav2-bringup
pkgdesc = Bringup scripts and configurations for the Nav2 stack
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/nav2_bringup/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-nav2-common
depends = ros2-humble-navigation2
depends = ros2-humble-slam-toolbox
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-nav2-bringup
diff --git a/PKGBUILD b/PKGBUILD
index db89839ec942..423c6e1efcd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_bringup
pkgname=ros2-humble-nav2-bringup
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="Bringup scripts and configurations for the Nav2 stack"
url="https://index.ros.org/p/nav2_bringup/"
arch=('any')
@@ -13,22 +14,23 @@ depends=(
'ros2-humble-navigation2'
'ros2-humble-slam-toolbox'
)
+makedepends=('cmake')
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}