summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:56:00 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:56:00 -0300
commita37baea1f7b381579773e9e1068137dff7543572 (patch)
tree48d14068e2e0dafb4c0250f6b0d5d721449b9586
downloadaur-a37baea1f7b381579773e9e1068137dff7543572.tar.gz
First version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30863a0b396a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ros2-humble-nav2-bringup
+ pkgdesc = Bringup scripts and configurations for the Nav2 stack
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://index.ros.org/p/nav2_bringup/
+ arch = any
+ depends = ros2-humble
+ depends = ros2-humble-nav2-common
+ depends = ros2-humble-navigation2
+ depends = ros2-humble-slam-toolbox
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
+ sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+
+pkgname = ros2-humble-nav2-bringup
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82eaf20073b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_bringup
+pkgname=ros2-humble-nav2-bringup
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="Bringup scripts and configurations for the Nav2 stack"
+url="https://index.ros.org/p/nav2_bringup/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-nav2-common'
+ 'ros2-humble-navigation2'
+ 'ros2-humble-slam-toolbox'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}