summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:48:29 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:48:29 -0300
commit40a6c636f762151be843570deb2abaec0feb666f (patch)
tree06ad2150c4c9b1dc213cbc18e419c2b284431d86
downloadaur-40a6c636f762151be843570deb2abaec0feb666f.tar.gz
First version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a13925282fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros2-humble-nav2-dwb-controller
+ pkgdesc = ROS2 controller (DWB) metapackage
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://index.ros.org/p/nav2_dwb_controller/
+ arch = any
+ depends = ros2-humble
+ depends = ros2-humble-costmap-queue
+ depends = ros2-humble-dwb-core
+ depends = ros2-humble-dwb-critics
+ depends = ros2-humble-dwb-msgs
+ depends = ros2-humble-dwb-plugins
+ depends = ros2-humble-nav-2d-msgs
+ depends = ros2-humble-nav-2d-utils
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
+ sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+
+pkgname = ros2-humble-nav2-dwb-controller
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a024039ea8bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_dwb_controller/nav2_dwb_controller
+pkgname=ros2-humble-nav2-dwb-controller
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="ROS2 controller (DWB) metapackage"
+url="https://index.ros.org/p/nav2_dwb_controller/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-costmap-queue'
+ 'ros2-humble-dwb-core'
+ 'ros2-humble-dwb-critics'
+ 'ros2-humble-dwb-msgs'
+ 'ros2-humble-dwb-plugins'
+ 'ros2-humble-nav-2d-msgs'
+ 'ros2-humble-nav-2d-utils'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}