summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:14:57 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:14:57 -0300
commitc1f4f0d8a0faf0ff524de5e041e2ce159ef53261 (patch)
tree3b66581c6b0b58b7456ad9410344c2d643e66e2f
parent7c64a68861b75eddfc74d1641ca4db7c575c5b98 (diff)
downloadaur-c1f4f0d8a0faf0ff524de5e041e2ce159ef53261.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1d9f08b7c3e..ee43bf99acb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ros2-humble-nav2-lifecycle-manager
pkgdesc = A controller/manager for the lifecycle nodes of the Navigation 2 system
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/nav2_lifecycle_manager/
arch = any
makedepends = ros2-humble-nav2-common
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-nav2-msgs
depends = ros2-humble-nav2-util
depends = ros2-humble-bondcpp
depends = ros2-humble-diagnostic-updater
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-nav2-lifecycle-manager
diff --git a/PKGBUILD b/PKGBUILD
index 6c69ffbc616a..19c448d2c2fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_lifecycle_manager
pkgname=ros2-humble-nav2-lifecycle-manager
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="A controller/manager for the lifecycle nodes of the Navigation 2 system"
url="https://index.ros.org/p/nav2_lifecycle_manager/"
arch=('any')
makedepends=(
'ros2-humble-nav2-common'
+ 'cmake'
)
depends=(
'ros2-humble'
@@ -18,21 +20,21 @@ depends=(
'ros2-humble-diagnostic-updater'
)
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}