summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:16:03 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:16:03 -0300
commite4b5217cde65786e790d44882def36a5a6ac1fa9 (patch)
treece523f75f19eaf3389abd62c3e506039e0906137
parent787e43e283cc02eb199145d145c31f4fce64f44e (diff)
downloadaur-e4b5217cde65786e790d44882def36a5a6ac1fa9.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11be8e74e485..91f1b0240498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ros2-humble-nav2-regulated-pure-pursuit-controller
pkgdesc = Regulated Pure Pursuit Controller
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/nav2_regulated_pure_pursuit_controller/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-nav2-util
depends = ros2-humble-nav2-msgs
depends = ros2-humble-nav2-common
depends = ros2-humble-nav2-costmap-2d
depends = ros2-humble-nav2-core
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-nav2-regulated-pure-pursuit-controller
diff --git a/PKGBUILD b/PKGBUILD
index f6d7a288caa7..607860ab159f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_regulated_pure_pursuit_controller
pkgname=ros2-humble-nav2-regulated-pure-pursuit-controller
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="Regulated Pure Pursuit Controller"
url="https://index.ros.org/p/nav2_regulated_pure_pursuit_controller/"
arch=('any')
@@ -15,23 +16,23 @@ depends=(
'ros2-humble-nav2-costmap-2d'
'ros2-humble-nav2-core'
)
+makedepends=('cmake')
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble \
- -DCMAKE_CXX_FLAGS="-Wno-error=maybe-uninitialized"
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}