summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:49:45 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:49:45 -0300
commit68d017d54fd977ff2bc85e8b1d4300bedca1beb7 (patch)
treefc03748927b1414a9131c20301a8e931bf7ba3f3
downloadaur-68d017d54fd977ff2bc85e8b1d4300bedca1beb7.tar.gz
First version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..891cf2a809dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ros2-humble-nav2-rviz-plugins
+ pkgdesc = Navigation 2 plugins for rviz
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://index.ros.org/p/nav2_rviz_plugins/
+ arch = any
+ depends = ros2-humble
+ depends = ros2-humble-nav2-util
+ depends = ros2-humble-nav2-lifecycle-manager
+ depends = qt5-base
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
+ sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+
+pkgname = ros2-humble-nav2-rviz-plugins
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9ea56421a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_rviz_plugins
+pkgname=ros2-humble-nav2-rviz-plugins
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="Navigation 2 plugins for rviz"
+url="https://index.ros.org/p/nav2_rviz_plugins/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-nav2-util'
+ 'ros2-humble-nav2-lifecycle-manager'
+ 'qt5-base'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}