summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:17:11 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:17:11 -0300
commit9a72adce471dd45470a4c42534e6513fd7c13901 (patch)
treec6c79621387f6f03fd511dd64bd0fd4533a8e7c0
parent3b3250597265acfcb7c24317a1a65f72bd53764f (diff)
downloadaur-9a72adce471dd45470a4c42534e6513fd7c13901.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb56ee295e88..6446c8fab5f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ros2-humble-nav2-theta-star-planner
pkgdesc = Theta* Global Planning Plugin
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/nav2_theta_star_planner/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-nav2-common
depends = ros2-humble-nav2-core
depends = ros2-humble-nav2-costmap-2d
depends = ros2-humble-nav2-msgs
depends = ros2-humble-nav2-util
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-nav2-theta-star-planner
diff --git a/PKGBUILD b/PKGBUILD
index bc1d34ee0a0f..6c68854168c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_theta_star_planner
pkgname=ros2-humble-nav2-theta-star-planner
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="Theta* Global Planning Plugin"
url="https://index.ros.org/p/nav2_theta_star_planner/"
arch=('any')
@@ -15,23 +16,23 @@ depends=(
'ros2-humble-nav2-msgs'
'ros2-humble-nav2-util'
)
+makedepends=('cmake')
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble \
- -DCMAKE_CXX_FLAGS="-Wno-error=maybe-uninitialized"
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}