summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:45:03 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:45:03 -0300
commit0379ed8e1ac4a8c29436167434b834c863a35c64 (patch)
tree410f965b316bd3181441cccc2b8387c8b0aa3a3b
downloadaur-0379ed8e1ac4a8c29436167434b834c863a35c64.tar.gz
First version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30a737ff58e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ros2-humble-nav2-velocity-smoother
+ pkgdesc = Nav2's Output velocity smoother
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://index.ros.org/p/nav2_velocity_smoother/
+ arch = any
+ makedepends = ros2-humble-nav2-common
+ depends = ros2-humble
+ depends = ros2-humble-nav2-util
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
+ sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+
+pkgname = ros2-humble-nav2-velocity-smoother
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6596d0355efa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_velocity_smoother
+pkgname=ros2-humble-nav2-velocity-smoother
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="Nav2's Output velocity smoother"
+url="https://index.ros.org/p/nav2_velocity_smoother/"
+arch=('any')
+makedepends=(
+ 'ros2-humble-nav2-common'
+)
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-nav2-util'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble \
+ -DCMAKE_CXX_FLAGS="-Wno-error=maybe-uninitialized"
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}