summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:17:37 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:17:37 -0300
commit4fc46c5416e1ed7f1f39b09a14768e7314eec17c (patch)
treec6cba463a77421c4d7d4a53dc1f15fe4ee711e29
parentaa3eeb259605a953e14cc0a2be9235116d0e797e (diff)
downloadaur-4fc46c5416e1ed7f1f39b09a14768e7314eec17c.tar.gz
update to 1.1.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1f5d26b7acd..ef61e6fc4591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = ros2-humble-nav2-velocity-smoother
pkgdesc = Nav2's Output velocity smoother
- pkgver = 1.1.6
- pkgrel = 2
+ pkgver = 1.1.7
+ pkgrel = 1
url = https://index.ros.org/p/nav2_velocity_smoother/
arch = any
makedepends = ros2-humble-nav2-common
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-nav2-util
- source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.6.tar.gz
- sha256sums = 43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1
+ source = https://github.com/ros-planning/navigation2/archive/refs/tags/1.1.7.tar.gz
+ sha256sums = 1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b
pkgname = ros2-humble-nav2-velocity-smoother
diff --git a/PKGBUILD b/PKGBUILD
index 3fbe090d9518..d51a3a0a8826 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_velocity_smoother
pkgname=ros2-humble-nav2-velocity-smoother
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="Nav2's Output velocity smoother"
url="https://index.ros.org/p/nav2_velocity_smoother/"
arch=('any')
makedepends=(
'ros2-humble-nav2-common'
+ 'cmake'
)
depends=(
'ros2-humble'
'ros2-humble-nav2-util'
)
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S navigation2-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble \
- -DCMAKE_CXX_FLAGS="-Wno-error=maybe-uninitialized"
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}