summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:18:37 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:18:37 -0300
commit88e81ce2bb689735ca124a80c37621aa06ecc05e (patch)
tree1900ec299e4aa7c97c09a9e45091afd6f7f58b32
parent7a18f56cbf687f2b55dc349f0ffa8594a9089d68 (diff)
downloadaur-88e81ce2bb689735ca124a80c37621aa06ecc05e.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7cf6960f9c3..8cb393cc7f65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-realtime-tools
pkgdesc = Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior
pkgver = 2.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/realtime_tools/
arch = any
+ makedepends = cmake
depends = ros2-humble
source = https://github.com/ros-controls/realtime_tools/archive/refs/tags/2.5.0.tar.gz
sha256sums = ca6f1514042168b39948ceb0290d13cfba0416487b9d3fcf470e2a06bab032b7
diff --git a/PKGBUILD b/PKGBUILD
index 21cb3e5c50ab..3568d7733392 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,30 @@
_pkgname=realtime_tools
pkgname=ros2-humble-realtime-tools
pkgver=2.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
url="https://index.ros.org/p/realtime_tools/"
arch=('any')
depends=(
'ros2-humble'
)
+makedepends=('cmake')
source=("https://github.com/ros-controls/realtime_tools/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('ca6f1514042168b39948ceb0290d13cfba0416487b9d3fcf470e2a06bab032b7')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S realtime_tools-$pkgver -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}