summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:53:21 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:53:21 -0300
commit98074c88c7955f7669d78862f836b2d8ae82733c (patch)
treeae258b25de88531eb9bb64097c0427c2472ede0f
downloadaur-98074c88c7955f7669d78862f836b2d8ae82733c.tar.gz
First version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e5811bd0bc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ros2-humble-realtime-tools
+ pkgdesc = Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://index.ros.org/p/realtime_tools/
+ arch = any
+ depends = ros2-humble
+ source = https://github.com/ros-controls/realtime_tools/archive/refs/tags/2.5.0.tar.gz
+ sha256sums = ca6f1514042168b39948ceb0290d13cfba0416487b9d3fcf470e2a06bab032b7
+
+pkgname = ros2-humble-realtime-tools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..032c7f8209a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=realtime_tools
+pkgname=ros2-humble-realtime-tools
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+url="https://index.ros.org/p/realtime_tools/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+)
+source=("https://github.com/ros-controls/realtime_tools/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('ca6f1514042168b39948ceb0290d13cfba0416487b9d3fcf470e2a06bab032b7')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S realtime_tools-$pkgver -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}