summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:57:53 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:57:53 -0300
commit53c6d61a99b3289e8d327c1a4970ad3be155b545 (patch)
tree94477363f016bc28c2fc1e530f82a1bec1006fd4
downloadaur-53c6d61a99b3289e8d327c1a4970ad3be155b545.tar.gz
First version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d193cc622860
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ros2-humble-smclib
+ pkgdesc = Converts a language-independent description of a state machine into the source code to support that state machine.
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://index.ros.org/p/smclib/
+ arch = any
+ depends = ros2-humble
+ source = https://github.com/ros/bond_core/archive/refs/tags/3.0.2.tar.gz
+ sha256sums = 16f0a741c238057146c50f4537d0e41c6c1842f7890a9fea1e782743ec9909f3
+
+pkgname = ros2-humble-smclib
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5301e0575873
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=smclib
+pkgname=ros2-humble-smclib
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Converts a language-independent description of a state machine into the source code to support that state machine."
+url="https://index.ros.org/p/smclib/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+)
+source=("https://github.com/ros/bond_core/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('16f0a741c238057146c50f4537d0e41c6c1842f7890a9fea1e782743ec9909f3')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S bond_core-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}