summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 08:38:55 -0300
committerAngelo Elias Dal Zotto2023-06-10 08:38:55 -0300
commit9972a68b1793b07f5b6df9ca5559d9cde188a17e (patch)
treeb52cd06e679c908604e8e73c5855e732de264d30
parent5dab99146b8637189296837302a6c401efe5c939 (diff)
downloadaur-9972a68b1793b07f5b6df9ca5559d9cde188a17e.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350e210a43d8..5088a0b0e8ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-smclib
pkgdesc = Converts a language-independent description of a state machine into the source code to support that state machine.
pkgver = 3.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/smclib/
arch = any
+ makedepends = cmake
depends = ros2-humble
source = https://github.com/ros/bond_core/archive/refs/tags/3.0.2.tar.gz
sha256sums = 16f0a741c238057146c50f4537d0e41c6c1842f7890a9fea1e782743ec9909f3
diff --git a/PKGBUILD b/PKGBUILD
index b5fdf4208394..1c9df38f233a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=bond_core
_pkgname=smclib
pkgname=ros2-humble-smclib
pkgver=3.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Converts a language-independent description of a state machine into the source code to support that state machine."
url="https://index.ros.org/p/smclib/"
arch=('any')
depends=(
'ros2-humble'
)
+makedepends=('cmake')
source=("https://github.com/ros/bond_core/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('16f0a741c238057146c50f4537d0e41c6c1842f7890a9fea1e782743ec9909f3')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S bond_core-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}