summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:53:34 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:53:34 -0300
commitb80af466f58671d199993db6e713106fd10e7df1 (patch)
tree0c0fb374dc04fc49f74cacb5c8e8afb27624566c
parente1bc6a3c6c5b367030cbebc35f5567c890781669 (diff)
downloadaur-b80af466f58671d199993db6e713106fd10e7df1.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f38c854d743..216941c0d453 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-teleop-tools-msgs
pkgdesc = The teleop_tools_msgs package
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/teleop_tools_msgs/
arch = any
+ makedepends = cmake
depends = ros2-humble
source = https://github.com/ros-teleop/teleop_tools/archive/refs/tags/1.3.0.tar.gz
sha256sums = 902e5fbdec909ee66e1b428df5076f125c231361211a1bd2a10b933fbc4d1f85
diff --git a/PKGBUILD b/PKGBUILD
index 4eb36e29da4c..acec077d703e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=teleop_tools
_pkgname=teleop_tools_msgs
pkgname=ros2-humble-teleop-tools-msgs
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="The teleop_tools_msgs package"
url="https://index.ros.org/p/teleop_tools_msgs/"
arch=('any')
+makedepends=('cmake')
depends=(
'ros2-humble'
)
@@ -14,18 +16,15 @@ source=("https://github.com/ros-teleop/teleop_tools/archive/refs/tags/${pkgver}.
sha256sums=('902e5fbdec909ee66e1b428df5076f125c231361211a1bd2a10b933fbc4d1f85')
prepare() {
- source /opt/ros/humble/setup.bash
-
- cmake -S teleop_tools-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+ source /opt/ros/humble/setup.bash
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cd "$_pkgroot-$pkgver/$_pkgname"
+ python -m build --wheel --no-isolation
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ cd "$_pkgroot-$pkgver/$_pkgname"
+ python -m installer --destdir="$pkgdir" --prefix="/opt/ros/humble" dist/*.whl
}