summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:52:38 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:52:38 -0300
commit34449f4c3919cd371f5f26a059851ff18cf47ab6 (patch)
treedca320fe9c90c08e885a24240f1df021d18381e6
downloadaur-34449f4c3919cd371f5f26a059851ff18cf47ab6.tar.gz
First version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bfcaaa7039e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ros2-humble-tl-expected
+ pkgdesc = C++11/14/17 std::expected with functional-style extensions
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://index.ros.org/p/tl_expected/
+ arch = any
+ depends = ros2-humble
+ source = https://github.com/PickNikRobotics/cpp_polyfills/archive/refs/tags/1.0.2.tar.gz
+ sha256sums = b7dde11bd51f5a7ded145fbc9a66b5ec304063117da73e19212757cb39830c21
+
+pkgname = ros2-humble-tl-expected
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f473182e21d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=tl_expected
+pkgname=ros2-humble-tl-expected
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="C++11/14/17 std::expected with functional-style extensions"
+url="https://index.ros.org/p/tl_expected/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+)
+source=("https://github.com/PickNikRobotics/cpp_polyfills/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('b7dde11bd51f5a7ded145fbc9a66b5ec304063117da73e19212757cb39830c21')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S cpp_polyfills-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}