summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:23:53 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:23:53 -0300
commit68de084e0d30ba04b99e6fb9e4de38bd9283aedf (patch)
treef0932d350f66dc951d678a33047055060a58eb67
parent05b516ade54d8024e39ee7f4024c3d4a60415fa0 (diff)
downloadaur-68de084e0d30ba04b99e6fb9e4de38bd9283aedf.tar.gz
update to 1.0.2-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0232c19ad516..85fdab358c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-tl-expected
pkgdesc = C++11/14/17 std::expected with functional-style extensions
pkgver = 1.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/tl_expected/
arch = any
+ makedepends = cmake
depends = ros2-humble
source = https://github.com/PickNikRobotics/cpp_polyfills/archive/refs/tags/1.0.2.tar.gz
sha256sums = b7dde11bd51f5a7ded145fbc9a66b5ec304063117da73e19212757cb39830c21
diff --git a/PKGBUILD b/PKGBUILD
index 67e8d79ef552..f398332b65a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=cpp_polyfills
_pkgname=tl_expected
pkgname=ros2-humble-tl-expected
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="C++11/14/17 std::expected with functional-style extensions"
url="https://index.ros.org/p/tl_expected/"
arch=('any')
depends=(
'ros2-humble'
)
+makedepends=('cmake')
source=("https://github.com/PickNikRobotics/cpp_polyfills/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('b7dde11bd51f5a7ded145fbc9a66b5ec304063117da73e19212757cb39830c21')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S cpp_polyfills-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}