summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:48:43 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:48:43 -0300
commit9339c52583629be15f0e17e372fe877af121ff81 (patch)
tree7326e4e09ce2d17e2a5fc77a272c25e2e3b13ae5
downloadaur-9339c52583629be15f0e17e372fe877af121ff81.tar.gz
First version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e5396e7f480
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ros2-humble-twist-mux
+ pkgdesc = Twist multiplexer, which multiplex several velocity commands (topics) and allows to priorize or disable them (locks).
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://index.ros.org/p/twist_mux/
+ arch = any
+ depends = ros2-humble
+ depends = ros2-humble-diagnostic-updater
+ source = https://github.com/ros-teleop/twist_mux/archive/refs/tags/4.1.0.tar.gz
+ sha256sums = 74df6cc84a9f24c7c794a4a7902b06683b535ffd4f9894b9fc663ab9d8fb01d4
+
+pkgname = ros2-humble-twist-mux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..887a6ee7f826
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=twist_mux
+pkgname=ros2-humble-twist-mux
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Twist multiplexer, which multiplex several velocity commands (topics) and allows to priorize or disable them (locks)."
+url="https://index.ros.org/p/twist_mux/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-diagnostic-updater'
+)
+source=("https://github.com/ros-teleop/twist_mux/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('74df6cc84a9f24c7c794a4a7902b06683b535ffd4f9894b9fc663ab9d8fb01d4')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S twist_mux-$pkgver -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}