summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:26:02 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:26:02 -0300
commitb03920706c93705669b44a596fc38fe7f0a4335a (patch)
tree87dd867112d9afd675f1bdfd086f99b050186475
parentde88c899d00770e44936cfa26df811a77f9c35b3 (diff)
downloadaur-b03920706c93705669b44a596fc38fe7f0a4335a.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b838aa341d9..4d3225995577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-twist-mux
pkgdesc = Twist multiplexer, which multiplex several velocity commands (topics) and allows to priorize or disable them (locks).
pkgver = 4.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/twist_mux/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = ros2-humble-diagnostic-updater
source = https://github.com/ros-teleop/twist_mux/archive/refs/tags/4.1.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index fe17fad8ec66..70b4296fc107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=twist_mux
pkgname=ros2-humble-twist-mux
pkgver=4.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Twist multiplexer, which multiplex several velocity commands (topics) and allows to priorize or disable them (locks)."
url="https://index.ros.org/p/twist_mux/"
arch=('any')
@@ -11,22 +11,23 @@ depends=(
'ros2-humble'
'ros2-humble-diagnostic-updater'
)
+makedepends=('cmake')
source=("https://github.com/ros-teleop/twist_mux/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('74df6cc84a9f24c7c794a4a7902b06683b535ffd4f9894b9fc663ab9d8fb01d4')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S twist_mux-$pkgver -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}