summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:31:23 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:31:23 -0300
commit41c926d4c3f05390d8e3568e160fbcadcca0066b (patch)
tree2bbe23c2e42123955f11e963a1fe02a6273d4989
parent4ec4c5234075b1e474f52030e4a476c99bb09b82 (diff)
downloadaur-41c926d4c3f05390d8e3568e160fbcadcca0066b.tar.gz
update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97626b3bf3db..280cd796e24a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ros2-humble-xacro
pkgdesc = A tool to construct shorter and more readable XML files by using macros that expand to larger XML expressions
pkgver = 2.0.9
- pkgrel = 2
+ pkgrel = 3
url = https://index.ros.org/p/xacro/
arch = any
+ makedepends = cmake
depends = ros2-humble
depends = python-yaml
source = https://github.com/ros/xacro/archive/refs/tags/2.0.9.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index cf348f9357d5..4d13060f0c64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgname=xacro
pkgname=ros2-humble-xacro
pkgver=2.0.9
-pkgrel=2
+pkgrel=3
pkgdesc="A tool to construct shorter and more readable XML files by using macros that expand to larger XML expressions"
url="https://index.ros.org/p/xacro/"
arch=('any')
@@ -10,20 +11,23 @@ depends=(
'ros2-humble'
'python-yaml'
)
+makedepends=('cmake')
source=("https://github.com/ros/xacro/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('a8802a5b48f7479bae1238e822ac4ebb47660221eb9bc40a608e899d60f3f7e4')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S xacro-$pkgver -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}