summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:53:07 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:53:07 -0300
commit977dcc27e97870fa253c505dc74b11e6be254f62 (patch)
treeee3e1472cb87cb687da671015bd3acc90be5de92
downloadaur-977dcc27e97870fa253c505dc74b11e6be254f62.tar.gz
First version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5004dfa6bfe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ros2-humble-xacro
+ pkgdesc = A tool to construct shorter and more readable XML files by using macros that expand to larger XML expressions
+ pkgver = 2.0.9
+ pkgrel = 1
+ url = https://index.ros.org/p/xacro/
+ arch = any
+ depends = ros2-humble
+ depends = python-yaml
+ source = https://github.com/ros/xacro/archive/refs/tags/2.0.9.tar.gz
+ sha256sums = a8802a5b48f7479bae1238e822ac4ebb47660221eb9bc40a608e899d60f3f7e4
+
+pkgname = ros2-humble-xacro
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64d1be837000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+pkgname=ros2-humble-xacro
+pkgver=2.0.9
+pkgrel=1
+pkgdesc="A tool to construct shorter and more readable XML files by using macros that expand to larger XML expressions"
+url="https://index.ros.org/p/xacro/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'python-yaml'
+)
+source=("https://github.com/ros/xacro/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('a8802a5b48f7479bae1238e822ac4ebb47660221eb9bc40a608e899d60f3f7e4')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S xacro-$pkgver -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}