summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorØystein Sture2023-07-13 10:54:07 +0200
committerØystein Sture2023-07-13 10:54:07 +0200
commitbca6d66ce905a15885720d070b1b204e975f8741 (patch)
tree816a82a675ef62f5361939685ad88d6a4b837815
parent90203cf3996c38939177815a3c3fcfa18bcac692 (diff)
downloadaur-bca6d66ce905a15885720d070b1b204e975f8741.tar.gz
Remove locale test and reduce RAM requirement for parallel build
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5b92136628c..6bcc83aedcc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,14 +48,6 @@ sha256sums=('SKIP'
'SKIP')
prepare() {
- # Check locale
- locale | grep LANG | grep -i UTF-8
- if [[ $? -ne 0 ]]; then
- printf "Locale must support UTF-8. See https://wiki.archlinux.org/index.php/locale
- or https://wiki.archlinux.org/index.php/locale ."
- exit 1
- fi
-
# Clone the repos
printf "Cloning ros2 repositories\n"
mkdir -p $srcdir/ros2/src
@@ -73,8 +65,8 @@ prepare() {
build() {
# Disable parallel build if RAM is low
- if [[ $(free | grep -Po "Mem:\s+\K\d+") < 16000000 ]]; then
- printf "\nRAM is smaller than 16 GB. Parallel build will be disabled for stability.\n\n"
+ if [[ $(free | grep -Po "Mem:\s+\K\d+") < 8000000 ]]; then
+ printf "\nRAM is smaller than 8 GB. Parallel build will be disabled for stability.\n\n"
export COLCON_EXTRA_ARGS="${COLCON_EXTRA_ARGS} --executor sequential"
fi