summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael DL6AKU2017-07-30 22:47:53 +0200
committerMichael DL6AKU2017-07-30 22:47:53 +0200
commitfeb742c895e2cf485288d4e5ec0bd297819d3f3f (patch)
tree9b3a83be43fc582730543c17379e9571343e6996
parentb0f5df5204349933721aae54739270a194141d6b (diff)
downloadaur-feb742c895e2cf485288d4e5ec0bd297819d3f3f.tar.gz
Changed License to MIT.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--rot13.c23
3 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7360ff17db46..12719f86d064 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Sun Feb 28 17:23:48 UTC 2016
+# Sun Jul 30 20:47:47 UTC 2017
pkgbase = rot13
pkgdesc = Converts text with ROT13 from STDIN to STDOUT or text given as arguments.
- pkgver = 2
- pkgrel = 5
+ pkgver = 3
+ pkgrel = 1
arch = i686
arch = x86_64
- license = WTFPL
+ license = MIT
source = rot13.c
- sha384sums = 9fd1dc60052d20e3c0675cedb2865e6cd5b7c4f1a9ceef724f2bbcd518ae25121731af9b1a47cd9ba74f2fc7ea9c37b5
+ sha384sums = 9b4fe06b2ecca3dd19ed909454f618948d917a23133856848ba0f5624b485ac3807de8d49d2a0cf4cd2c210c537ccec0
pkgname = rot13
diff --git a/PKGBUILD b/PKGBUILD
index 22a33af8b493..29e1fbf6cf67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Michael Duell <michael.duell@rub.de> PGP-Fingerprint: FF8C D50E 66E9 5491 F30C B75E F32C 939C 5566 FF77
pkgname=rot13
-pkgver=2
-pkgrel=5
+pkgver=3
+pkgrel=1
pkgdesc="Converts text with ROT13 from STDIN to STDOUT or text given as arguments."
arch=('i686' 'x86_64')
-license=('WTFPL')
+license=('MIT')
source=('rot13.c')
build() {
@@ -17,4 +17,4 @@ package() {
install -d "${pkgdir}/usr/bin/"
install -m755 rot13 "${pkgdir}/usr/bin/rot13"
}
-sha384sums=('9fd1dc60052d20e3c0675cedb2865e6cd5b7c4f1a9ceef724f2bbcd518ae25121731af9b1a47cd9ba74f2fc7ea9c37b5')
+sha384sums=('9b4fe06b2ecca3dd19ed909454f618948d917a23133856848ba0f5624b485ac3807de8d49d2a0cf4cd2c210c537ccec0')
diff --git a/rot13.c b/rot13.c
index 791b0c4a6773..eaa9ee139d7c 100644
--- a/rot13.c
+++ b/rot13.c
@@ -1,12 +1,27 @@
/**
* @author Michael Duell <michael.duell@rub.de>
*
- * Released under the WTFPL.
+ * Released under the MIT license.
*
- * DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
- * TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+ * Copyright (c) 2017 Michael Duell <michael.duell@rub.de>
*
- * 0. You just DO WHAT THE FUCK YOU WANT TO.
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
+ * of this software and associated documentation files (the "Software"), to deal
+ * in the Software without restriction, including without limitation the rights
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in all
+ * copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
**/
#include <stdlib.h>