summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Bauer2023-12-18 09:11:54 +0100
committerMichael Bauer2023-12-18 09:12:59 +0100
commit4019e3e160114f140ee1c9b7b0397319529af3be (patch)
treea1c3a09f46c7db9f364136eca8517a5ca24d9a32
parent6c63c74dd538693707b5c81f67e7958914e35c7a (diff)
downloadaur-4019e3e160114f140ee1c9b7b0397319529af3be.tar.gz
make all src filenames unique to fix SHA256 issues
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 802f3a6ba51a..8f5b40cd97b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rotki-bin
pkgdesc = A portfolio tracking, analytics, accounting and tax reporting application that respects your privacy
pkgver = 1.31.0
- pkgrel = 1
+ pkgrel = 2
url = https://rotki.com
arch = x86_64
license = BSD
@@ -12,8 +12,8 @@ pkgbase = rotki-bin
noextract = rotki-1.31.0.tar.xz
options = !strip
source = rotki-1.31.0.tar.xz::https://github.com/rotki/rotki/releases/download/v1.31.0/rotki-linux_x64-v1.31.0.tar.xz
- source = rotki.png::https://raw.githubusercontent.com/rotki/rotki/v1.31.0/frontend/app/public/assets/images/rotki_1024x1024.png
- source = LICENSE::https://github.com/rotki/rotki/raw/v1.31.0/LICENSE.md
+ source = rotki-1.31.0-rotki.png::https://raw.githubusercontent.com/rotki/rotki/v1.31.0/frontend/app/public/assets/images/rotki_1024x1024.png
+ source = rotki-1.31.0-LICENSE::https://github.com/rotki/rotki/raw/v1.31.0/LICENSE.md
sha256sums = 8c09429510ac78b494de8f5b02684e6301cdd272c4306519076b7b75823989fc
sha256sums = 391e4e2bfe352660a151b8f7143f8057ad43aafb256d4e3dfbf15546c3541270
sha256sums = eb6f58a98d8bdb6d3c8fee3817543589f3cd0921d14748fa0630edff2d4c08b0
diff --git a/PKGBUILD b/PKGBUILD
index f3a90abf8a01..5d57c382c744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rotki-bin
pkgver=1.31.0
-pkgrel=1
+pkgrel=2
pkgdesc='A portfolio tracking, analytics, accounting and tax reporting application that respects your privacy'
arch=('x86_64')
url="https://rotki.com"
@@ -14,9 +14,10 @@ noextract=("${pkgname%-bin}-${pkgver}.tar.xz")
depends=('gtk3'
'nss')
makedepends=('gendesk')
-source=("${pkgname%-bin}-${pkgver}.tar.xz::https://github.com/rotki/rotki/releases/download/v${pkgver}/rotki-linux_x64-v${pkgver}.tar.xz"
- "rotki.png::https://raw.githubusercontent.com/rotki/rotki/v${pkgver}/frontend/app/public/assets/images/rotki_1024x1024.png"
- "LICENSE::https://github.com/rotki/rotki/raw/v${pkgver}/LICENSE.md")
+sourceprefix=${pkgname%-bin}-${pkgver}
+source=("${sourceprefix}.tar.xz::https://github.com/rotki/rotki/releases/download/v${pkgver}/rotki-linux_x64-v${pkgver}.tar.xz"
+ "${sourceprefix}-rotki.png::https://raw.githubusercontent.com/rotki/rotki/v${pkgver}/frontend/app/public/assets/images/rotki_1024x1024.png"
+ "${sourceprefix}-LICENSE::https://github.com/rotki/rotki/raw/v${pkgver}/LICENSE.md")
sha256sums=('8c09429510ac78b494de8f5b02684e6301cdd272c4306519076b7b75823989fc'
'391e4e2bfe352660a151b8f7143f8057ad43aafb256d4e3dfbf15546c3541270'
'eb6f58a98d8bdb6d3c8fee3817543589f3cd0921d14748fa0630edff2d4c08b0')
@@ -24,11 +25,11 @@ sha256sums=('8c09429510ac78b494de8f5b02684e6301cdd272c4306519076b7b75823989fc'
package() {
install -d "${pkgdir}/opt/" "${pkgdir}/usr/bin"
ln -s /opt/rotki/rotki "${pkgdir}/usr/bin"
- tar xvf ${pkgname%-bin}-${pkgver}.tar.xz -C "${pkgdir}/opt/"
+ tar xvf ${sourceprefix}.tar.xz -C "${pkgdir}/opt/"
mv "${pkgdir}/opt/rotki"* "${pkgdir}/opt/rotki"
- convert rotki.png -resize 256x256 rotki256.png
+ convert ${sourceprefix}-rotki.png -resize 256x256 rotki256.png
install -Dm644 rotki256.png "${pkgdir}/usr/share/pixmaps/rotki.png"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 ${sourceprefix}-LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
gendesk -f -n --pkgname "${pkgname%-bin}" \
--pkgdesc "$pkgdesc" \
--name "Rotki" \