summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-10-16 19:49:40 +0200
committerCarsten Teibes2014-10-16 19:49:40 +0200
commit6f2ab00b0b7b58d00518eae3498b9ece8c545e12 (patch)
tree5fddaf4056b327b12eb4a899894aea054748a722
downloadaur-6f2ab00b0b7b58d00518eae3498b9ece8c545e12.tar.gz
[add] rott-svn
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
-rwxr-xr-xrott.sh4
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71555bb91cd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rott-svn
+ pkgdesc = "Rise of the Triad" is a high quality first-person perspective 3D action game (development version)
+ pkgver = 1.1.2.r278
+ pkgrel = 1
+ url = http://icculus.org/rott/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = svn
+ depends = sdl_mixer
+ source = rott::svn://svn.icculus.org/rott/trunk
+ source = rott.sh
+ sha256sums = SKIP
+ sha256sums = 19f5c5ccf4b6bd592a8e119f8172a0cb180caf1ab831b820786000dbeaf9651e
+
+pkgname = rott-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5b5b0d210c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=rott-svn
+pkgver=1.1.2.r278
+pkgrel=1
+pkgdesc='"Rise of the Triad" is a high quality first-person perspective 3D action game (development version)'
+arch=('i686' 'x86_64')
+license=('GPL2')
+makedepends=('svn')
+depends=('sdl_mixer')
+url="http://icculus.org/rott/"
+source=(rott::"svn://svn.icculus.org/rott/trunk"
+ "rott.sh")
+sha256sums=('SKIP'
+ '19f5c5ccf4b6bd592a8e119f8172a0cb180caf1ab831b820786000dbeaf9651e')
+
+pkgver() {
+ cd rott
+ local ver="$(svnversion)"
+ printf "1.1.2.r%s" "${ver//[[:alpha:]]}" # TODO: fix hardcoded version
+}
+
+build() {
+ cd rott
+ # We can not just build all editions, because of a Makefile quirk. Object files will overlap when parallel building is used (-j2).
+ # You can choose your edition(s) here:
+ make rott-huntbgin # shareware
+ make rott-darkwar # commercial
+ make rott-rottcd # cd
+ #make rott-rottsite # site license cd
+}
+
+package() {
+ cd rott
+ # copy all editions and launcher
+ install -d "$pkgdir"/usr/bin
+ install -m755 rott-* "$pkgdir"/usr/bin
+ install -m755 misc/runrott.sh "$pkgdir"/usr/bin/runrott
+ install -m755 ../rott.sh "$pkgdir"/usr/bin/rott
+ # doc
+ install -Dm644 doc/rott.6 "$pkgdir"/usr/share/man/man6/rott.6
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 doc/*.txt "$pkgdir"/usr/share/doc/$pkgname
+ # .desktop entry
+ install -Dm644 misc/rott.png "$pkgdir"/usr/share/pixmaps/rott.png
+ install -Dm644 misc/rott.desktop "$pkgdir"/usr/share/applications/rott.desktop
+
+ # set the cd version as default (as it is a common version, for example still sold at gog.com)
+ # You can also use all other targets from the build() function, for example 'huntbgin' for the shareware version
+ sed 's|EDITION|rottcd|' -i "$pkgdir"/usr/bin/rott
+}
diff --git a/rott.sh b/rott.sh
new file mode 100755
index 000000000000..4105c1e2d7af
--- /dev/null
+++ b/rott.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+mkdir -p $HOME/.rott
+cd $HOME/.rott && exec rott-EDITION