summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-02-05 21:54:00 -0500
committerVincent Grande2021-02-05 21:54:00 -0500
commitbf8002bcba88f16b5234999ec2039525a412a16e (patch)
tree3110947bc26e3335be349f0c44ea3175581ed6b5
downloadaur-bf8002bcba88f16b5234999ec2039525a412a16e.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcca3940c2a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rottexpr-git
+ pkgdesc = Source port for the original Rise of the Triad
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/LTCHIPS/rottexpr
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = sdl2
+ depends = sdl2_mixer
+ provides = rottexpr
+ conflicts = rottexpr
+ source = git+https://github.com/LTCHIPS/rottexpr
+ md5sums = SKIP
+
+pkgname = rottexpr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50173d3aafaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+
+pkgname=rottexpr-git
+pkgver=1
+pkgrel=1
+pkgdesc='Source port for the original Rise of the Triad'
+arch=('i686' 'x86_64')
+url="https://github.com/LTCHIPS/rottexpr"
+license=('GPL3')
+conflicts=("rottexpr")
+provides=("rottexpr")
+depends=('sdl2' 'sdl2_mixer')
+makedepends=(git)
+source=("git+https://github.com/LTCHIPS/rottexpr")
+md5sums=('SKIP')
+
+pkgver() {
+ cd rottexpr
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd rottexpr
+
+ autoreconf -fi
+ make
+}
+
+package() {
+ cd rottexpr
+ make DESTDIR="$pkgdir/" install
+}