summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2018-11-05 15:31:04 +0100
committerCedric Girard2018-11-05 15:32:45 +0100
commit64b6600f8b33aa39fce4abf34eaffd933a0bac66 (patch)
treec69564d62a03a701864b46b8d7f7c6b5e9ebf17a
downloadaur-64b6600f8b33aa39fce4abf34eaffd933a0bac66.tar.gz
First packaged version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD84
-rw-r--r--apache.conf7
-rw-r--r--roundcubemail.tmpfiles2
4 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2824e04984c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = roundcubemail-git
+ pkgdesc = A PHP web-based mail client
+ pkgver = 1.4.beta.r108.g802ed0dc6
+ pkgrel = 1
+ url = https://roundcube.net/
+ arch = any
+ license = GPL
+ makedepends = php-composer
+ makedepends = git
+ depends = php
+ depends = php-gd
+ optdepends = python2
+ provides = roundcubemail
+ conflicts = roundcubemail
+ backup = etc/webapps/roundcubemail/.htaccess
+ backup = etc/webapps/roundcubemail/apache.conf
+ source = git+https://github.com/roundcube/roundcubemail.git
+ source = apache.conf
+ source = roundcubemail.tmpfiles
+ sha256sums = SKIP
+ sha256sums = c90981405527ebaf153a407af6b8178b41d078bd4472d63b837b3b4cd5ae36b0
+ sha256sums = b0baf067cd6c09938991890ab8c87ba4bad06987781c5accbed86b95e35c2a56
+
+pkgname = roundcubemail-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16180365aded
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Cedric Girard <cgirard [dot] archlinux [at] valinor [dot] fr>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=roundcubemail-git
+pkgver=1.4.beta.r108.g802ed0dc6
+pkgrel=1
+pkgdesc="A PHP web-based mail client"
+arch=('any')
+url="https://roundcube.net/"
+license=('GPL')
+depends=('php' 'php-gd')
+makedepends=('php-composer' 'git')
+optdepends=('python2')
+provides=('roundcubemail')
+conflicts=('roundcubemail')
+backup=('etc/webapps/roundcubemail/.htaccess'
+ 'etc/webapps/roundcubemail/apache.conf')
+source=("git+https://github.com/roundcube/roundcubemail.git"
+ "apache.conf"
+ "roundcubemail.tmpfiles")
+sha256sums=('SKIP'
+ 'c90981405527ebaf153a407af6b8178b41d078bd4472d63b837b3b4cd5ae36b0'
+ 'b0baf067cd6c09938991890ab8c87ba4bad06987781c5accbed86b95e35c2a56')
+
+pkgver() {
+ cd "roundcubemail"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"/roundcubemail
+ sed -i \
+ -e "s|RCUBE_INSTALL_PATH . 'temp.*|'/var/cache/roundcubemail';|" \
+ -e "s|RCUBE_INSTALL_PATH . 'logs.*|'/var/log/roundcubemail';|" \
+ config/defaults.inc.php \
+ program/lib/Roundcube/rcube_config.php
+
+ sed -i 's!"dest": "program/js/tinymce"!"dest": "program/js/tinymce/langs"!' jsdeps.json
+
+ mv composer.json-dist composer.json
+ php -d extension=gd.so /usr/bin/composer install --no-dev
+ bin/install-jsdeps.sh
+ bin/jsshrink.sh
+
+ cd skins/elastic
+ lessc -x styles/styles.less > styles/styles.css
+ lessc -x styles/print.less > styles/print.css
+ lessc -x styles/embed.less > styles/embed.css
+ cd ../..
+
+ bin/updatecss.sh
+ bin/cssshrink.sh
+ #rm transifexpull.sh package2composer.sh importgettext.sh exportgettext.sh README.md INSTALL UPGRADING, LICENSE, CHANGELOG
+ rm -rf tests/ public_html/ installer/ .tx*
+
+}
+
+
+package() {
+ mkdir -p "$pkgdir"/etc/webapps/roundcubemail
+ mkdir -p "$pkgdir"/usr/share/webapps
+ cd "$pkgdir"/usr/share/webapps
+ cp -ra "$srcdir"/roundcubemail roundcubemail
+ cd roundcubemail
+
+ mv .htaccess "$pkgdir"/etc/webapps/roundcubemail/
+ ln -s /etc/webapps/roundcubemail/.htaccess .htaccess
+
+ mv config "$pkgdir"/etc/webapps/roundcubemail/
+ ln -s /etc/webapps/roundcubemail/config config
+
+ install -Dm0644 "$srcdir"/apache.conf "$pkgdir"/etc/webapps/roundcubemail/apache.conf
+
+ rm -rf temp logs
+ find "$pkgdir" -name .git -exec rm -rf {} \; || true
+
+# sed -i "s|"$srcdir"/roundcubemail/vendor/pear-pear.php.net/Console_CommandLine/data|/usr/share/webapps/roundcubemail/vendor/pear-pear.php.net|g" \
+# vendor/pear-pear.php.net/Console_CommandLine/Console/CommandLine/XmlParser.php
+
+# sed -i "s|"$srcdir"/roundcubemail|/usr/share/webapps/roundcubemail|g" \
+# vendor/pear-pear.php.net/Crypt_GPG/bin/crypt-gpg-pinentry \
+# vendor/pear-pear.php.net/Crypt_GPG/Crypt/GPG/Engine.php \
+# vendor/pear-pear.php.net/Crypt_GPG/Crypt/GPG/PinEntry.php
+}
diff --git a/apache.conf b/apache.conf
new file mode 100644
index 000000000000..e7e2b35a02d9
--- /dev/null
+++ b/apache.conf
@@ -0,0 +1,7 @@
+Alias /roundcube "/usr/share/webapps/roundcubemail"
+<Directory "/usr/share/webapps/roundcubemail">
+ AllowOverride All
+ Options FollowSymlinks
+ Require all granted
+ php_admin_value open_basedir "/tmp/:/var/cache/roundcubemail:/usr/share/webapps/roundcubemail:/etc/webapps/roundcubemail:/usr/share/pear/:/var/log/roundcubemail"
+</Directory>
diff --git a/roundcubemail.tmpfiles b/roundcubemail.tmpfiles
new file mode 100644
index 000000000000..17b6367322e7
--- /dev/null
+++ b/roundcubemail.tmpfiles
@@ -0,0 +1,2 @@
+d /var/cache/roundcubemail 0750 http http - -
+d /var/log/roundcubemail 0750 http http - -